Aller au contenu principal
Sujet: Pb avec FreeBox ! (Lu 352 fois) sujet précédent - sujet suivant
0 Membres et 1 Invitédans ce sujet

Pb avec FreeBox !

Bonjour,

Je viens de déménager, j'ai laissé ma LiveBox au profit d'une FreeBox.
(Config : Box android, Kodi 17.6, BDD Maria DB5 sur NAS Synology))
Je n'arrivait plus à scrapper, et me suis rendu compte qu'il fallait changer la passerelle de 192.168.0.1 vers 192.168.1.254 sur mon NAS.
NAS qui me propose de télécharger la dernière version DSM 7, mais attention Maria DB5 n'est plus pris en compte, il faut passer à la DB10. Et je me rends compte que les mots de passe 'simples' ne sont plus autorisés. Et le système me met en garde constamment concernant mon compte 'admin' qu'il faudrait désactiver pour ne pas me faire hacker... Ok je créé donc un nouveau compte et désactive 'admin'. Bref dans mes fichers de config XML Kodi j'ai mis le port pour Maria DB10, le nouveau compte pour remplacer 'admin', avec le nouveau mot de passe, ainsi que le nouveau mot de passe de l'utilisateur 'kodi'...
Mais rien n'y fait, j'ai tout désinstallé, réinstallé de 0, supprimé la BDD MyVideos107, mais toujours rien ??
Au moment de déclarer la source, j'arrive à naviguer dans les répertoires, jusqu'à voir les fichiers mkv. Mais au moment de scrapper,  rien ne se passe, et quand je clique sur la source (par exemple 'Séries') ;  j'ai 'Partage distant / Impossible de se connecter au serveur réseau'

Qu'ai-je loupé, svp ? Un port à ouvrir quelque part ? Est-ce que Free a des DNS particulières ?
Ma log est >ici<. Si quelqu'un peut jeter un oeil et me dire ce qu'il en pense, ce serait super sympa  :-*

(A voir la log on dirait qu'il manque un username / password, pourtant ils sont bien là.. enfi je pense)

Merci.

Christophe.

Re : Pb avec FreeBox !

Répondre #1
Bonjour,
Fait un essai avec l'ip du nas plutôt que son nom.
A vérifier également le port de la base de donnée (3306 par défaut).
Voilou

Re : Pb avec FreeBox !

Répondre #2
Bonjour totoonline,

Ca marchait très bien il y a é semaines avant mon déménagement, avec la Livebox dont l'adresse était '192.168.1.1' (et non 192.168.0.1 comme je pensais).
Je vois que cette année il y a eu des soucis entre Freebox & SMB.. Je me demande si je ne devrais pas résilier Free et repasser chez Orange ?

Certains d'entre vous sont bien chez Free + Synology + Maria DB10 + User admin désactivé  + mot de passe non vide et 'complexe' obligatoire (j'avais user 'kodi' mdp 'kodi', j'ai du en mettre un plus complexe).. pas de soucis chez vous, ou j'essuie les plâtres ?

J'ai remplacé 'diskstation' par son adresse IP '192.168.1.88' et remplacé 3306 par 3307, mais toujours pareil : une fois le répertoire des médias + scrapper et paramètres choisis, rien ne se lance.

Rebooté la Freebox puis le Synology, puis le PC (Où je tente de refaire ma config, plus simple que sur boitier TV android), recontrolé les fichiers XML dans Userdata :
- advancedsettings.xml
- mediasources.xml
- passwords.xml
- sources.xml
et relancé Kodi en mode Debug (dernire log jointe), toujours pas de scrap qui se lance ?!!
et dans la log :
23:34:05.245 T:10484   ERROR: Unable to create new database
23:34:07.281 T:10484   ERROR: Unable to open database: MyVideos107 [2003](Can't connect to MySQL server on '192.168.1.88' (10061))

Mais pourquoi ? :'(

Merci pour votre aide,

Christophe.

Re : Pb Scraping

Répondre #3
Bonjour,

J'ai suivi les conseils trouvés ici : https://www.nas-forum.com/forum/topic/60097-base-centralis%C3%A9-kodi/
(J'ai activé NFS mais utilise toujours SMB, à présent de V1 à V3 et plus juste V1 à V2, activé le TCP/IP,..)

A présent : la BDD MyVideos107 se créé, la source 'vidéos' est conservée en tant que contenant des Films et devant être scrappée avec Universal Movie Scraper... jusqu'à hier ce n'étatit pas le cas.
Le scrap se lance enfin ! MAIS le nom des .mkv défile toutes les secondes, comme auparavant, mais je ne vois pas passer le nom du film tel qu'il existe dans IMDB.
Exemple : je vois passer 'tt0022100.mkv' - juste après je devrais voir s'inscrire (en dessous du nom du fichier ou à la place, je ne sais plus) le nom du film correspondant : 'M le maudit', ou son titre original, en allemand. Mais non. Et la BDD reste désepérément avec 2 malheureuses lignes (Path 1 = smb://DISKSTATION/video/_Films_IMDB_/) et Version = 107).

Ci-joint un extrait de la log  - où on voit que
* l'URL IMDB est bien trouvée : https://www.imdb.com/title/tt0022100/
* mais qu'il ne trouve pas d'information : WARNING: No information found for item 'smb://DISKSTATION/video/_Films_IMDB_/tt0022100.mkv', it won't be added to the library.

Alors que je n'avais pas de souci, avant.  Je ne pense plus que la Freebox est en cause, mais le plugin UMS - dont j'ai la dernière version, voire IMDB ?
(Le site a été remanié, la présentation n'est plus la même : peut-être les informations ne sont plus cherchées au bon endroit, dans le flux HTML, si les tags ont changés de nom ? Il me semble que dans ce cas, le WebScraping serait à adapter.)
[Edit] Fichier modifié en 'M le maudit.mkv', à présent le scrap se fait, le film est dispo dans Kodi.. mais que lui :(
         Autre scraper testé, il ne reconnait pas mes films, dont les noms sont leur identifiant IMDB.

12:12:54.623 T:7536   DEBUG: ------ Window Init (DialogExtendedProgressBar.xml) ------
12:12:54.630 T:4240  NOTICE: VideoInfoScanner: Starting scan ..
12:12:54.631 T:1904   DEBUG: CAnnouncementManager - Announcement: OnScanStarted from xbmc
12:12:54.631 T:1904   DEBUG: GOT ANNOUNCEMENT, type: 16, from xbmc, message OnScanStarted
12:12:55.259 T:4240   DEBUG: XFILE::CWin32SMBDirectory::ConnectAndAuthenticate: Connected to "\\DISKSTATION\video" with username "nimda" and with password
12:12:55.477 T:4240   DEBUG: Previous line repeats 1 times.
12:12:55.477 T:4240   DEBUG: VideoInfoScanner: Scanning dir 'smb://DISKSTATION/video/_Films_IMDB_/' as not in the database
12:12:55.484 T:4240   DEBUG: XFILE::CWin32SMBDirectory::ConnectAndAuthenticate: Connected to "\\DISKSTATION\video" with username "nimda" and with password
12:12:55.486 T:4240   DEBUG: VideoInfoScanner: No NFO file found. Using title search for 'smb://DISKSTATION/video/_Films_IMDB_/tt0022100.mkv'
12:12:55.486 T:4240   DEBUG: ADDON::CScraper::FindMovie: Searching for 'tt0022100' using Universal Movie Scraper scraper (path: 'C:\Users\Christophe\AppData\Roaming\Kodi\addons\metadata.universal', content: 'movies', version: '4.1.18')
12:12:55.495 T:4240   DEBUG: scraper: CreateSearchUrl returned <url>https://www.imdb.com/find?q=tt0022100&s=tt|accept-language=en-us</url>
12:12:55.495 T:4240   DEBUG: CurlFile::ParseAndCorrectUrl() adding custom header option 'accept-language: en-us'
12:12:55.495 T:4240   DEBUG: CurlFile::Open(0CD118A8) https://www.imdb.com/find?q=tt0022100&s=tt
12:12:55.495 T:4240    INFO: XCURL::DllLibCurlGlobal::easy_aquire - Created session to https://www.imdb.com
12:12:58.029 T:4240   DEBUG: CCurlFile::Open - effective URL: <https://www.imdb.com/title/tt0022100/>
12:12:58.529 T:4240   DEBUG: CScraperUrl::Get: Using "UTF-8" charset for HTML "https://www.imdb.com/find?q=tt0022100&s=tt|accept-language=en-us"
12:12:58.596 T:4240   DEBUG: scraper: GetSearchResults returned <?xml version="1.0" encoding="iso-8859-1" standalone="yes"?><results></results>
12:12:58.596 T:4240   DEBUG: ADDON::CScraper::FindMovie: Searching for 'tt0022100' using Universal Movie Scraper scraper (path: 'C:\Users\Christophe\AppData\Roaming\Kodi\addons\metadata.universal', content: 'movies', version: '4.1.18')
12:12:58.596 T:4240   DEBUG: scraper: CreateSearchUrl returned <url>https://www.imdb.com/find?q=tt0022100&s=tt|accept-language=en-us</url>
12:12:58.596 T:4240   DEBUG: CurlFile::ParseAndCorrectUrl() adding custom header option 'accept-language: en-us'
12:12:58.596 T:4240   DEBUG: CurlFile::Open(0CD118A8) https://www.imdb.com/find?q=tt0022100&s=tt
12:12:59.340 T:7536   DEBUG: ------ Window Deinit (Pointer.xml) ------
12:12:59.634 T:4240   DEBUG: CCurlFile::Open - effective URL: <https://www.imdb.com/title/tt0022100/>
12:13:00.139 T:4240   DEBUG: CScraperUrl::Get: Using "UTF-8" charset for HTML "https://www.imdb.com/find?q=tt0022100&s=tt|accept-language=en-us"
12:13:00.196 T:4240   DEBUG: scraper: GetSearchResults returned <?xml version="1.0" encoding="iso-8859-1" standalone="yes"?><results></results>
12:13:00.196 T:4240 WARNING: No information found for item 'smb://DISKSTATION/video/_Films_IMDB_/tt0022100.mkv', it won't be added to the library.

Help, please ! (Peut-être quelqu'un sait à qui m'adresser pour question sur le plugin Universal Movie Scraper ?)
[Edit] : trouvé ceci dans le addon.xml : <forum>https://forum.kodi.tv/showthread.php?tid=129821</forum>
          Il semble qu'il faile peut etre utiliser une version plus récente de Kodi, je vais tenter..
 
Merci,

Christophe.


 
Simple Audio Video Embedder